Halftone Lens App Reviews

0 add

Won't run on iPhone yet

Requires iOS 4.3. Current iPhone software (June 1) is 4.2.8. Thus it will not install. Runs on iPad (4.3.3) but bombs frequently.

  • send link to app